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Overview

Overview

The following is a short guide to the use of the CINEMA 4D Exchange application with ARCHICAD.
Please bear in mind that this short guide does not replace the comprehensive CINEMA 4D Exchange
Reference Guide; we recommend that you use both documents together.

CINEMA 4D Exchange is MAXON'’s high-end 3D modeling, rendering and animation solution.
Installing the CINEMA 4D Exchange for ARCHICAD allows CINEMA 4D Exchange to function as a
powerful visualization tool or a graphical GDL modeler and editor tightly integrated with
ARCHICAD. The connection between the two applications, using the C4D format (version R19),
offers a streamlined 3D design workflow on both Macintosh and Windows platforms.

With the CINEMA 4D Exchange add-on connection, elements created in CINEMA 4D can be
transferred to ARCHICAD as GDL objects.

Notes:
e With the introduction of the Morph tool in ARCHICAD 16, the CINEMA 4D Exchange Add-on is
no longer necessary for some of these functions.

e For architectural visualization, CineRender, the new built-in rendering engine of ARCHICAD,
provides most of the rendering capabilities of CINEMA 4D. For professional purposes and to
further exploit the texture mapping, rendering and animating capabilities of CINEMA 4D, please
use the built-in Export to CINEMA 4D command in ARCHICAD (from the Render pop-up button
of the PhotoRendering palette). This export feature lets you precisely export the ARCHICAD
model, together with the surface- and the rendering settings, into CINEMA 4D with one click.

Software Requirements

ARCHICAD and CINEMA 4D Exchange must be installed on your computer prior to the installation of
the ARCHICAD add-on.

The latest ARCHICAD add-on can be downloaded free of charge from the following webpage:
http://www.graphisoft.com/products/archicad/addons/cinema_4d/cinema4d_download.html
Important Note for ARCHICAD 19 and earlier:

Before exporting with CINEMA 4D Exchange, make sure that ARCHICAD Working Units are set to
centimeter. If the programs use different working units, you may find scaling problems after the
data exchange.

A Working Units ? X
(B Model unit v
Decimals 0 ~

As of ARCHICAD 20, the units of exported ARCHICAD models will be converted automatically in
CINEMA 4D.
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Usage Scenario 1:

Exporting CINEMA 4D Exchange
File for Visualization with
Scene Update functionality

By exporting the whole project from ARCHICAD to CINEMA 4D Exchange, users can take advantage
of its animation and rendering capabilities to create motion or still pictures.

New CINEMA 4D Exchange Scene Creation

1. After completing the modeling in ARCHICAD, go to the 3D window, and display all the model
content you want to use for visualization.

2. Select File > Save as command and select the CINEMA 4D Exchange file format from the Save
dialog’s Format list.

3. Click Save.
4. Open CINEMA 4D Exchange, and select the Open command to open the model as a new scene.

Updating a Previously Exported ARCHICAD
Model in CINEMA 4D Exchange

If the model has been modified in ARCHICAD after exporting as a CINEMA 4D Exchange file, it is
possible to apply the modeling changes to the CINEMA 4D Exchange scene in the following manner:

1. In ARCHICAD, go to the 3D window and display all the model content you want to use for
visualization.

2. Select the File > Save as command, select the CINEMA 4D Exchange file format in the Save
dialog’s Format list and enter a new name for the file.

3. Click Save.

4. Open the original file in CINEMA 4D Exchange that you want to update.

5. Select the File > Merge command and select the new CINEMA 4D Exchange file that contains
the new version of the model.

Important: During the update process, not only the scene object geometries will be refreshed,
but the object hierarchy as well. If the updated file is saved with different grouping options (e.g.
by Class/by Material) than the original CINEMA 4D Exchange file, the CINEMA 4D Exchange
scene hierarchy will be modified to match the new grouping scheme, which might cause data
loss!

For configuration options, see the “CINEMA 4D Exchange Export / Import Settings” section.
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Usage Scenario 2: CINEMA 4D Exchange File Import

Usage Scenario 2:
CINEMA 4D Exchange File Import

To convert a CINEMA 4D Exchange file to an ARCHICAD GDL object, use the ARCHICAD Open or
Merge command.

I Openfile *
Look in: | AC 20 Cinema 4D v| (< W5 il v| [&
* MName ° Date modified Ty
_ CINEMA 4D logok 11/18/2015 2:02 PM Fil
luickaccess Graphics 11/18/20152:02PM  Fil
- tex 2/10/2016 11:09 AM Fil
{|_| Outdoor East Wing.cdd 2/10/2016 11:09 AM Cé
Desktop
m
Libraries
. >
This PC
. DLaunch a new instance of ARCHICAD
MNetwork
File name: Qutdoor East Wing - | I Open
Files of type: CINEMA 4D File (*.c4d) ~ Cancel

Note: You can only import CINEMA 4D Exchange files that have been saved with the CINEMA 4D
Exchange Melange Exchange option. Set this option in the CINEMA 4D Exchange Edit >
Preferences dialog box.

) Preferences
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Usage Scenario 3: Bidirectional Free-Form Modeling

Usage Scenario 3:
Bidirectional Free-Form Modeling

ARCHICAD

When you need a free-form CINEMA 4D Exchange shape in your ARCHICAD project, or you would
like to modify an existing ARCHICAD element using CINEMA 4D Exchange, do the following:

e To create a new CINEMA 4D Exchange object, use the File > Interoperability > CINEMA 4D
Exchange > Create new element in CINEMA 4D Exchange command, available while working in
the 3D window.

¢ To edit elements, select them and use the Edit selected elements in CINEMA 4D Exchange
command, available while working in the 3D window only.

File Edit View Design Document Options Tearmwork Window Test Help

[ New o= O 2 -EEX | A T
E; Open 4 Geomeny Method: Structure:

[} CloseProject  Ctrl+Shift+W Marph - General vl T O G || ceneric - prerasrIca
_ []] [3D / Alll x [ _T[South Elevation]

Save Ctrl+S

Bl Saveas... Ctrl+Shift+S

;j Publish BIMzx Hyper-model...

| Interoperability
External Content » @ IFC 4
Libraries and Objects H DXF-DWG L4
Info ’ Element Properties ’
Plot Setup... 3D Studio 4
E Plot... CINEMA 4D ‘q Edit zelected elements in CINEMA 4D
Page Setup.. Chrl+ Shifts P Import Point Clouds... & Create new element in CINEMA 4D
5 Print... Crl+P Place Mesh from Surveyors Data... % Remove CINEMA 4D preferences
Exit Q| Send Model to Google Earth CINEMA 4D settings

By default, the commands are at the bottom of your Interoperability menu, but you can customize
your work environment anytime.

In either case, ARCHICAD will launch CINEMA 4D Exchange and transfer the content of the 3D
window. After the transfer, ARCHICAD will switch into “Synchronization” mode. During this time,
no user interaction is possible in ARCHICAD and you should work in CINEMA 4D Exchange only.

Note: ARCHICAD will ask you to locate CINEMA 4D Exchange manually the first time you use it.
This is a one-time-only question; ARCHICAD will remember this location later. If the location of
CINEMA 4D Exchange changes on the computer (e.g. because of an upgrade), you can re-set the
location using Remove CINEMA 4D Exchange preferences in the File > Interoperability >
CINEMA 4D Exchange menu.

| CIMEMA 4D R1Z Exchange

_rﬂ Remove CINEMA 40 preferences

[ CIMEMA 4D settings
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Usage Scenario 3: Bidirectional Free-Form Modeling

In this case, the next time you select “Create new element in CINEMA 4D Exchange” or “Edit
selected elements in CINEMA 4D Exchange”, you will be prompted to navigate to the CINEMA 4D
Exchange executable location.

If you decide to cancel the CINEMA 4D Exchange editing process, you can click the “Break
connection to CINEMA 4D Exchange” button in the synchronization dialog, but in this case you will
not be able to get the model back from CINEMA 4D Exchange.

Important: If you start CINEMA 4D Exchange separately from ARCHICAD, don’t use the “Send
back to ARCHICAD” command in CINEMA 4D Exchange. You can use the connection only if:
You start CINEMA 4D Exchange from ARCHICAD and

ARCHICAD is still in “Synchronization” mode

In order to restore the connection, do the following:

1.
2.

Save your scene as a CINEMA 4D Exchange file in CINEMA 4D Exchange.

Switch to ARCHICAD, activate the 3D window and establish the connection with CINEMA 4D
Exchange using the Create new element in CINEMA 4D Exchange command.

In CINEMA 4D Exchange, merge the previously saved CINEMA 4D Exchange file.

Note: For configuration options, see the Export Parameters section.

CINEMA 4D Exchange

In CINEMA 4D Exchange, you will receive the entire contents of ARCHICAD’s 3D window.

CINEMA 4D Exchange Add-On User Guide for ARCHICAD

Elements which were not selected for editing will be in the “ARCHICAD environment” object
group on the “ARCHICAD environment” layer. Elements of this group will be semi-transparent in
CINEMA 4D Exchange. Their purpose is to help you position your design correctly. Editing these
elements will have no effect on their ARCHICAD representation, and changes will be lost when you
return to ARCHICAD. If you wish to modify these elements, then return to ARCHICAD, select them
in the 3D window and use the “Edit selected elements in CINEMA 4D Exchange” command.

If you used the “Edit selected elements in CINEMA 4D Exchange” command in ARCHICAD, the
selected elements will be listed outside the ARCHICAD environment group and you can edit
them freely. The objects will be hierarchically organized according to the current CINEMA 4D
Exchange export settings (see the “CINEMA 4D Exchange Export / Import Settings” section for
further info).




Usage Scenario 3: Bidirectional Free-Form Modeling

When you finish the CINEMA 4D Exchange design, you can send the information from the Editor
window back to ARCHICAD using the File > Send to ARCHICAD command. This returns the model to
ARCHICAD and keeps CINEMA 4D Exchange open for the next editing cycle.

If you created new elements in CINEMA 4D Exchange, ARCHICAD will automatically place the new
objects at exactly the same location as in CINEMA 4D Exchange.

If you edited selected elements in CINEMA 4D Exchange, the original elements will be replaced with
the new geometry.

The material and geometry information of CINEMA 4D Exchange is saved in the retrieved GDL
object and will be used the next time you edit the object, but the content of ARCHICAD
environment is newly generated during each export.

CINEMA 4D Exchange Add-On User Guide for ARCHICAD 9



CINEMA 4D Exchange Export / Import Settings

CINEMA 4D Exchange Export / Import
Settings

Grouping Options

ARCHICAD Elements can be exported either “by Class” or “by Material” (Surface). In both cases, the
elements’ polygons are filtered out in hierarchy groups. To create a still image in CINEMA 4D
Exchange, use the “by Material” option. All used materials form an individual group with all linked
polygons in a quite simple structure, so replacing a material on the related surfaces becomes an
easy task.

I CINEMA 4D Settings ? X

Select how your elements should be grouped in
CINEMA 4D:

(® by Class (Wall, Slab, etc))
Oby Surface

Optional content:

Cameras

Geometry scaling factor:

Reset to default

Cancel OK

For freeform modeling, use the “by Class” method, which provides the freedom of easy element
editing. All elements are grouped by type and element_id.

Cameras

By default, ARCHICAD exports only the current 3D viewport. The “Cameras” option exports all
existing camera from the project.

Notes: The exported CINEMA 4D Exchange file contains the following entities:
e The model geometry of the visible layers, including the effects of SEO operations
e Converted Surfaces
e Camera view of the ARCHICAD 3D window and camera positions
e Lamps
Scene update functionality is available in CINEMA 4D Exchange R11.027 version and up.
The add-on creates a folder called “tex” next to the exported file, which contains all data (such as

Surface textures) needed for CINEMA 4D Exchange to read and open the file correctly. Please do
not remove this folder.
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Element Settings

Element Settings

Surfaces

Surfaces will be converted to CINEMA 4D Exchange materials during the first export, and CINEMA
4D Exchange materials will be converted into Surfaces during every return process. As ARCHICAD
and CINEMA 4D Exchange have different approaches to modeling materials, the conversions may
suffer data loss in some cases. However, once an object has been edited or created in CINEMA 4D
Exchange and then converted to a GDL object, the GDL object’s parameters will include the
CINEMA 4D Exchange material settings, so no data loss will occur in subsequent freeform editing
processes.

Note: In case of bitmap textures, the bitmap images are stored in the “tex” folder next to the
CINEMA 4D Exchange project file. To avoid missing textures in the object, do not remove this
folder or its content.

Although ARCHICAD and CINEMA 4D Exchange have different ways of projecting textures,
projections are converted during export. UVW mapping information is also stored with the CINEMA
4D Exchange polygon objects, so if you find that a converted projection of a texture is not exact
enough for your needs, you can select “UVW Mapping” as projection in the object’s texture tag. For
objects that will act as solids in ARCHICAD, you should use projected textures instead of UVW
mapping, because GDL objects with solid operation capabilities can be displayed correctly in
ARCHICAD only if they use projected textures. If you create an object that won’t take part in a solid
operation in ARCHICAD, you can use UVW mapped textures and choose “preserve textures” as the
Model Behavior setting of the retrieved GDL object (see below).

Limitations:

e Ifthe element’s polygons are grouped “by Material” in the hierarchy, only UVW mapping can be
used for the texture projection.

e The current version uses only the Internal Rendering Engine settings of the Surfaces. As
reflectivity is not supported by the Internal Rendering Engine, the export process considers
highly shiny Surfaces to be reflective, while the less shiny Surfaces are converted to CINEMA 4D
Exchange materials with specular light properties.

Hotspots in ARCHICAD Objects

If no hotspots are defined in CINEMA 4D Exchange, ARCHICAD’s default hotspots will be shown
with the returned GDL object. You can bypass the defaults and define custom hotspots by following
these steps:

1. Create a Null object in CINEMA 4D Exchange and change its name to “Hotspot”.

Objects | Tools Sele

I| Null Object |
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Element Settings

2. Move it to the desired location in the Editor windows.

Objects

10 Hotspot |

It will be converted into a 3D hotspot in the ARCHICAD GDL object and will be located at the exact
position of the CINEMA 4D Exchange Hotspot object.

Edge Status of Objects

You are able to control the smoothing of the object’s polygons at the edges.

To adjust the angle at which two adjoining polygons will be smoothed at the edges, do the
following:

1. Select the object in CINEMA 4D Exchange.

2. Right-click on the object in the Object Manager and select the “Phong” tag from the CINEMA 4D
Exchange Tags.

® - :
. CINEMA 4D Tags &

10
10
0
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Element Settings

3. Click on the appearing Tag marker in the Object Manager.

* Atributes

4. lts properties will appear in the Attribute Manager.

5. Switch Angle limit on and set your angle. The entered number will be the maximum angle at
which two surfaces are smoothed into each other.

Number of Polygons in Objects

The number of polygons in your CINEMA 4D Exchange objects greatly influences the speed of your
ARCHICAD. To check the number of polygons:

1. Select all your objects, except the ARCHICAD environment, in the Object Manager
2. Right-click on them and select Object Information
3. The number of polygons is displayed in the appearing dialog

* ) Information

The fewer polygons the objects have, the faster ARCHICAD will be. If you think your object is too
big, you have several options for reducing the number of polygons in CINEMA 4D Exchange prior to
returning the object to ARCHICAD:

e The Optimize command will throw away polygons/points/edges which are closer than the
entered Tolerance value.

i*) Optimize

0.01 rf

Ok Cancel

¢ Polygon Reduction reduces the number of polygons for the objects to which it is applied.

According to our tests, objects containing fewer than 20,000 polygons work well in ARCHICAD. Of
course, placing multiple objects will increase calculation time.
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Element Settings

ARCHICAD Object Display Settings

The floor plan symbol of the created CINEMA 4D Exchange objects can be fine-tuned in ARCHICAD
using the following object settings:

1. Floor Plan display — choose one of the 5 options.

Floor Plan Display Projected [¥] v Projectzd

Show Projection To Floor Plan Range Pro_ec(e.d w hiQuerhead
b i Symbolic View

Model Behaviour OutLines Only
I 2D Representation Overhead All

2. Model Behavior — By default, the object coming back from CINEMA 4D Exchange contains two
3D geometry models.

¢ The Solid model can be used in Solid Element Operations, but has restrictions on displayable
Surfaces, so texturing may differ from the one used in CINEMA 4D Exchange.

e The Texture model stores the custom texture information you assigned to certain surfaces of
the object in CINEMA 4D Exchange, so the correctness of the displayed textures is limited only
by the Internal Rendering Engine of ARCHICAD. To avoid duplicated geometry in the project,
which may cause performance problems, select one of these behaviors.

= Model Behaviour

‘- Model behaviour Preserve Solids E ¥ Preserve Solids

¥ 2N Renresentation Preserve Textures

3. 2D Representation — Depending on the Floor plan display selected, different parameters may
be listed here.
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Element Dependency

Element Dependency

Certain ARCHICAD elements, such as a window and the wall it is placed into, are interrelated. If you
edit such elements in CINEMA 4D Exchange, the related elements will behave as follows:

Editing a Wall

If you select a wall that contains doors/windows, those elements will also be editable in CINEMA 4D
Exchange. When they return from CINEMA 4D Exchange, then both the wall and the doors/
windows will be part of the GDL object.

Editing a Door/Window

If you select a door/window and wish to edit it in CINEMA 4D Exchange, then only the selected
door/window will be transferred as editable.

When such a door/window returns from CINEMA 4D Exchange, the original opening in the wall will
be removed. You must place a new empty opening manually. The new GDL object will be placed in
the same position as it occupied in CINEMA 4D Exchange.

If you edit two doors/windows at the same time, they will return as a single GDL object even if they
are in separate walls.
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